Give is built to work in as many possible environments as possible. Nevertheless, in order to have the best experience and the best Support from us, there are some minimum requirements.

While it’s possible you could run Give with versions older than the minimums we list below, please understand that you will have the most reliable experience with Give if you at least meet or exceed these requirements. Further, we cannot provide Priority Support to environments that do not meet these minimums.

WordPress Version

Minimum WordPress Version: 4.8.5

Give is built to be as backward compatible as possible. Just like WordPress itself, we believe in backward compatibility. Nevertheless, we believe you’ll have the best experience and get the best Support if you are on version 4.8.5 or higher.

Also, keep in mind that the third decimal of a WordPress release is always considered a security release; so whatever version you are on

jQuery Version

Minimum jQuery Version: the version that comes with WordPress

Some themes and plugins remove the WordPress default version of jQuery and load up (aka “enqueue”) their own version of jQuery. This is a very bad practice which can lead to security vulnerabilities or general dysfunction on your WordPress website. Give requires that you are using only the version of jQuery that is loaded by WordPress and no other.

We understand that you may not know whether your site is enqueueing a custom version of jQuery or not. Just be aware that if you request Support for Give, our first advice to you may be how to remove that custom version.

Server Environment

Recommended Minimum PHP Version: 5.6

PHP is the backbone of WordPress. WordPress itself now recommends version 7.0 to all WordPress users, and we do as well. But the minimum we currently support is version 5.6.

If you find that your host does not support PHP 5.6 or higher, we suggest seriously considering moving hosts. To underscore this point, see the “Supported Versions” chart on the PHP website, showing the security patches for PHP 5.6 will stop as of December 2017. That means that all older versions of PHP no longer even get security updates. Running older versions of PHP is a security risk, and especially in the context of donors giving to your organization and having their giving history saved there, you are obligated to protect that data from being exposed to breaches.

Minimum cURL version: 7.40

In order to transmit sensitive donor information from your site to your payment gateway, your server must support TLS, “Transit Security Layer”. That technology is a combination of cURL, HTTPS, and other technologies. TLS is effectively a modern replacement for SSL.

This article describes the difference between SSL and TLS very well. To quote:

Subsequent versions of TLS — v1.1 and v1.2 are significantly more secure and fix many vulnerabilities present in SSL v3.0 and TLS v1.0.  For example, the BEAST attack that can completely break websites running on older SSL v3.0 and TLS v1.0 protocols. The newer TLS versions, if properly configured, prevent the BEAST and other attack vectors and provide many stronger ciphers and encryption methods.

For that reason, we require a minimum cURL version of 7.40. This is often an overlooked technology with older web hosts. You might find that it is severely outdated on your server. We’ve seen versions of cURL with some customers that are more than 7 years old. Again, if your host is unable or unwilling to update your environment to cURL 7.40 or higher we highly recommend finding a new host.

Review the cURL Version History to see how old your version is.

Minimum TLS version: 1.2

Because SSL certificates are required for all online transactions, and because Give is dependent on this technology, we require all Give users to have a valid SSL certificate that passes TLS 1.2 tests. Without this, we cannot guarantee that your donations will be safe or successful.

Minimum Give Versions

Occasionally we’ll release a new Add-on version that requires a minimum Give Core version. This is often because the Add-on depends on new code built into that new Core version. Generally speaking, if you update an Add-on without updating Give Core what will happen is that you’ll see an admin notification telling you that the updated Add-on couldn’t be activated because Give Core is outdated. In cases like that, all you need to do is update Give to the latest version and you’re all set.